aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cea2bd2..632465c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,17 @@ LIBODB_BOOST([], [odb_tests_boost=no])
AM_CONDITIONAL([ODB_TESTS_BOOST], [test x$odb_tests_boost != xno])
+# Check for Qt
+#
+odb_tests_qt=yes
+LIBQTCORE([],[odb_tests_qt=no])
+
+# Check for libodb-qt
+#
+LIBODB_QT([], [odb_tests_qt=no])
+
+AM_CONDITIONAL([ODB_TESTS_QT], [test x$odb_tests_qt != xno])
+
# Check which database we are using.
#
DATABASE