aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConstantin Michael <constantin@codesynthesis.com>2011-03-30 15:54:27 +0200
committerConstantin Michael <constantin@codesynthesis.com>2011-04-22 18:04:37 +0200
commit75f8ef2dcddea1260a31491c97a26d30a18fce6c (patch)
treeea388153b6a8073b3ade61c12f86d76d9ea501f1 /configure.ac
parent242363e630f2f541bcf1b7133f21ab2730587c4f (diff)
Add code for Qt profile dist build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cea2bd2..632465c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,6 +54,17 @@ LIBODB_BOOST([], [odb_tests_boost=no])
AM_CONDITIONAL([ODB_TESTS_BOOST], [test x$odb_tests_boost != xno])
+# Check for Qt
+#
+odb_tests_qt=yes
+LIBQTCORE([],[odb_tests_qt=no])
+
+# Check for libodb-qt
+#
+LIBODB_QT([], [odb_tests_qt=no])
+
+AM_CONDITIONAL([ODB_TESTS_QT], [test x$odb_tests_qt != xno])
+
# Check which database we are using.
#
DATABASE