aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 259551d..109b4cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,14 @@ THREADS
AM_CONDITIONAL([ODB_TESTS_THREADS], [test x$threads != xnone])
+# Check for C++11.
+#
+CXX11([HAVE_CXX11], [Compiling in the C++11 mode.])
+
+# Check for TR1 <memory> availability.
+#
+TR1_MEMORY
+
# Check for the ODB compiler.
#
ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
@@ -41,10 +49,6 @@ ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB
#
LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
-# Check for TR1 <memory> availability.
-#
-TR1_MEMORY
-
# Check for boost.
#
odb_tests_boost=yes