aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-02-24 09:58:48 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-02-24 09:58:48 +0200
commit50b4de07844ca2a5781d7845115d7bd9e7c8f003 (patch)
treee433a7f4977729d1f6481d33729787a830ef959e /configure.ac
parent0306a05023c3857bc0ee7a3bf8355a5665f78d11 (diff)
C++11 support (initial infrastructure)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 259551d..109b4cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,14 @@ THREADS
AM_CONDITIONAL([ODB_TESTS_THREADS], [test x$threads != xnone])
+# Check for C++11.
+#
+CXX11([HAVE_CXX11], [Compiling in the C++11 mode.])
+
+# Check for TR1 <memory> availability.
+#
+TR1_MEMORY
+
# Check for the ODB compiler.
#
ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
@@ -41,10 +49,6 @@ ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB
#
LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
-# Check for TR1 <memory> availability.
-#
-TR1_MEMORY
-
# Check for boost.
#
odb_tests_boost=yes