summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules99
1 files changed, 99 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..c2ab5af
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,99 @@
+#! /usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+ARCH_CPU := $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+
+ifeq ($(ARCH_CPU),amd64)
+ARCH_CPU := x86_64
+endif
+
+ifeq ($(ARCH_CPU),i386)
+ARCH_CPU := i686
+endif
+
+ARCH_KERNEL_OS := $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+
+ARCH := $(ARCH_CPU)-$(ARCH_KERNEL_OS)
+
+$(warning building for host system: $(ARCH))
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+ # Add here commands to compile the package.
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ # Add here commands to clean up after the build process.
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ # Add here commands to install the package into debian/xsd.
+
+# Build architecture-independent files here.
+binary-indep: build install
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs NEWS
+ dh_installdocs README
+ dh_installdocs doc/default.css doc/xsd.xhtml
+ dh_installdocs doc/cxx/tree/
+ dh_installdocs doc/cxx/parser/
+ dh_installman doc/xsd.1
+ cp -rL bin $(CURDIR)/debian/xsd/usr/
+ mkdir -p $(CURDIR)/debian/xsd/usr/include/
+ cp -rL libxsd/xsd $(CURDIR)/debian/xsd/usr/include/
+ cp -rL examples $(CURDIR)/debian/xsd/usr/share/doc/xsd/
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+## dh_installman
+## dh_link
+## dh_strip # no stripping at the moment
+ dh_compress -X.hxx -X.ixx -X.txx -X.cxx -Xmakefile -X.xsd -X.xml -X.xhtml -X.pdf -X.doxygen
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+## dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure