summaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am35
1 files changed, 0 insertions, 35 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
deleted file mode 100644
index 8a36dd0..0000000
--- a/odb/Makefile.am
+++ /dev/null
@@ -1,35 +0,0 @@
-# file : odb/Makefile.am
-# copyright : Copyright (c) 2009-2019 Code Synthesis Tools CC
-# license : GNU GPL v3; see accompanying LICENSE file
-
-plugindir = @plugindir@
-
-bin_PROGRAMS = odb
-plugin_LTLIBRARIES = odb.la
-
-AM_CPPFLAGS = -I'$(top_builddir)' -I'$(top_srcdir)'
-
-# Note: not passed by libtool when linking odb.so. Seems to be harmless for
-# now.
-#
-AM_CXXFLAGS = -std=c++0x
-
-EXTRA_DIST = __path__(headers) __path__(extra_dist)
-
-# Plugin.
-#
-odb_la_SOURCES = __path__(plugin_sources) __path__(common_sources)
-odb_la_LDFLAGS = -module -shrext .so -avoid-version
-
-# Remove the .la file from the final install.
-#
-install-data-hook:
- rm -f '$(DESTDIR)$(plugindir)/odb.la'
-
-# Driver.
-#
-odb_SOURCES = __path__(driver_sources) __path__(common_sources)
-
-# Make sure common sources are compiled differently.
-#
-odb_CXXFLAGS = $(AM_CXXFLAGS)