aboutsummaryrefslogtreecommitdiff
path: root/tracer/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tracer/template/Makefile.am')
-rw-r--r--tracer/template/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tracer/template/Makefile.am b/tracer/template/Makefile.am
new file mode 100644
index 0000000..09e4f09
--- /dev/null
+++ b/tracer/template/Makefile.am
@@ -0,0 +1,25 @@
+# file : tracer/template/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+noinst_PROGRAMS = driver
+driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
+
+TESTS=$(top_builddir)/tester
+TESTS_ENVIRONMENT=top_builddir=$(top_builddir);
+
+m4_ifelse(__value__(odb_options),,,
+
+# ODB compilation.
+#
+driver_SOURCES += test.hxx test-odb.cxx
+BUILT_SOURCES = test-odb.hxx
+CLEANFILES = test-odb.hxx test-odb.ixx test-odb.cxx
+
+ODB = @ODB@
+ODBFLAGS = @ODBFLAGS@
+
+test-odb.hxx: test.hxx
+ $(ODB) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
+)