aboutsummaryrefslogtreecommitdiff
path: root/qt/common/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'qt/common/template/Makefile.am')
-rw-r--r--qt/common/template/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/qt/common/template/Makefile.am b/qt/common/template/Makefile.am
index a15f7b8..4101392 100644
--- a/qt/common/template/Makefile.am
+++ b/qt/common/template/Makefile.am
@@ -24,5 +24,9 @@ ODB = @ODB@
ODBFLAGS = @ODBFLAGS@
ODBCPPFLAGS = @ODBCPPFLAGS@
+if HAVE_CXX11
+ODBFLAGS += --std c++11
+endif
+
test-odb.hxx: test.hxx
$(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<