aboutsummaryrefslogtreecommitdiff
path: root/evolution/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'evolution/template/Makefile.am')
-rw-r--r--evolution/template/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/evolution/template/Makefile.am b/evolution/template/Makefile.am
new file mode 100644
index 0000000..b5cd2d7
--- /dev/null
+++ b/evolution/template/Makefile.am
@@ -0,0 +1,49 @@
+# file : evolution/template/Makefile.am
+# copyright : Copyright (c) 2009-2013 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+EXTRA_DIST = __file__(extra_dist)
+
+noinst_PROGRAMS = driver
+driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
+LDADD = $(top_builddir)/libcommon/common/libcommon.la
+AM_CPPFLAGS = -I'$(top_builddir)/libcommon' -I'$(top_srcdir)/libcommon'
+AM_CPPFLAGS += -I'$(builddir)' -I'$(srcdir)'
+
+TESTS=$(top_srcdir)/evolution/tester
+TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
+
+ODB = @ODB@
+ODBFLAGS = @ODBFLAGS@
+ODBCPPFLAGS = @ODBCPPFLAGS@
+
+if HAVE_CXX11
+ODBFLAGS += --std c++11
+endif
+
+# test1.hxx
+#
+driver_SOURCES += test1.hxx
+nodist_driver_SOURCES = test1-odb.cxx
+BUILT_SOURCES = test1-odb.hxx
+CLEANFILES = test1-odb.hxx test1-odb.ixx test1-odb.cxx test1.sql model.xml
+
+test1-odb.hxx: test1.hxx
+ $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options1) --changelog model.xml $<
+
+# test2.hxx
+#
+driver_SOURCES += test2.hxx
+nodist_driver_SOURCES += test2-odb.cxx
+BUILT_SOURCES += test2-odb.hxx
+CLEANFILES += test2-odb.hxx test2-odb.ixx test2-odb.cxx test2.sql \
+test2-002-pre.sql test2-002-post.sql test2-003-pre.sql test2-003-post.sql
+
+test2-odb.hxx: test2.hxx
+ $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options2) --changelog model.xml $<
+
+# Make sure test2.hxx is compiled before test1.hxx since they share the
+# changelog. Also add dependency on model.hxx
+#
+test2-odb.hxx: test1-odb.hxx
+test1-odb.hxx test2-odb.hxx: model.hxx