aboutsummaryrefslogtreecommitdiff
path: root/oracle/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:29:37 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:29:37 +0200
commit34a371625b17428aa0e35488499a2a7b69b0da27 (patch)
tree36bea5761f603245de6e5220f318e532d379dbf5 /oracle/template/Makefile.am
parente67a19c220db8315914a74be7b3527535e480c87 (diff)
C++11 support in automake and VC++ projects, portability fixes
Diffstat (limited to 'oracle/template/Makefile.am')
-rw-r--r--oracle/template/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/oracle/template/Makefile.am b/oracle/template/Makefile.am
index d7d5d84..7beba9c 100644
--- a/oracle/template/Makefile.am
+++ b/oracle/template/Makefile.am
@@ -26,6 +26,10 @@ ODB = @ODB@
ODBFLAGS = @ODBFLAGS@
ODBCPPFLAGS = @ODBCPPFLAGS@
+if HAVE_CXX11
+ODBFLAGS += --std c++11
+endif
+
test-odb.hxx: test.hxx
$(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
)