aboutsummaryrefslogtreecommitdiff
path: root/common/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-08 21:23:37 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-08 21:23:37 +0200
commitff5bb2accee87c24ee64e8fdcf5169e674c4b7b4 (patch)
tree321a74c1f48331cb44e3b90943501646c5024836 /common/template/Makefile.am
parentb3b1fac433a20e5ab6abb3729ecc5473a658718b (diff)
Add suppor for VC++ build
Diffstat (limited to 'common/template/Makefile.am')
-rw-r--r--common/template/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/common/template/Makefile.am b/common/template/Makefile.am
index b2fc122..ca3a3d5 100644
--- a/common/template/Makefile.am
+++ b/common/template/Makefile.am
@@ -3,13 +3,15 @@
# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
# license : GNU GPL v2; see accompanying LICENSE file
+EXTRA_DIST = __file__(extra_dist)
+
noinst_PROGRAMS = driver
driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
-driver_LDADD = $(top_builddir)/libcommon/libcommon.la
+driver_LDADD = $(top_builddir)/libcommon/common/libcommon.la
driver_CPPFLAGS = -I'$(top_builddir)/libcommon' -I'$(top_srcdir)/libcommon'
TESTS=$(top_builddir)/tester
-TESTS_ENVIRONMENT=top_builddir=$(top_builddir);
+TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
# ODB compilation.
#