aboutsummaryrefslogtreecommitdiff
path: root/boost/common/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2011-02-17 14:50:11 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2011-02-17 14:50:11 +0200
commit5aaec95bbfb066130ecac03eece3813cee61a3e1 (patch)
tree87c24d1b6afe613c31076cf7b417a7e2b7188994 /boost/common/template/Makefile.am
parent29e7db53cb1db2c4d743d4756b8ac3fee28ab8ea (diff)
Add test infrastructure for boost profile
Diffstat (limited to 'boost/common/template/Makefile.am')
-rw-r--r--boost/common/template/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/boost/common/template/Makefile.am b/boost/common/template/Makefile.am
new file mode 100644
index 0000000..4ab6efe
--- /dev/null
+++ b/boost/common/template/Makefile.am
@@ -0,0 +1,28 @@
+# file : boost/common/template/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+EXTRA_DIST = __file__(extra_dist)
+
+noinst_PROGRAMS = driver
+driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
+LDADD = $(top_builddir)/libcommon/common/libcommon.la
+AM_CPPFLAGS = -I'$(top_builddir)/libcommon' -I'$(top_srcdir)/libcommon'
+
+TESTS=$(top_builddir)/tester
+TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
+
+# ODB compilation.
+#
+driver_SOURCES += test.hxx
+nodist_driver_SOURCES = test-odb.cxx
+BUILT_SOURCES = test-odb.hxx
+CLEANFILES = test-odb.hxx test-odb.ixx test-odb.cxx
+
+ODB = @ODB@
+ODBFLAGS = @ODBFLAGS@
+ODBCPPFLAGS = @ODBCPPFLAGS@
+
+test-odb.hxx: test.hxx
+ $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<