aboutsummaryrefslogtreecommitdiff
path: root/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'template/Makefile.am')
-rw-r--r--template/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/template/Makefile.am b/template/Makefile.am
index d59aa5b..f39fbad 100644
--- a/template/Makefile.am
+++ b/template/Makefile.am
@@ -42,5 +42,9 @@ ODB = @ODB@
ODBFLAGS = @ODBFLAGS@
ODBCPPFLAGS = @ODBCPPFLAGS@
+if HAVE_CXX11
+ODBFLAGS += --std c++11
+endif
+
__path__(odb_header_stem)-odb.hxx: __path__(odb_header_stem).hxx
$(ODB) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<