aboutsummaryrefslogtreecommitdiff
path: root/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:31:38 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:31:38 +0200
commitd43a0047151d490dcd061e3f105bfc4eb9fac854 (patch)
tree93546657349fc5d8529376b7235ecc01bdaa73f2 /template/Makefile.am
parentc55878df67c400d9ac940ee2d8dbd6e922af5ac3 (diff)
New example that shows C++11 support, build infrastructure for C++11
Diffstat (limited to 'template/Makefile.am')
-rw-r--r--template/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/template/Makefile.am b/template/Makefile.am
index d59aa5b..f39fbad 100644
--- a/template/Makefile.am
+++ b/template/Makefile.am
@@ -42,5 +42,9 @@ ODB = @ODB@
ODBFLAGS = @ODBFLAGS@
ODBCPPFLAGS = @ODBCPPFLAGS@
+if HAVE_CXX11
+ODBFLAGS += --std c++11
+endif
+
__path__(odb_header_stem)-odb.hxx: __path__(odb_header_stem).hxx
$(ODB) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<