aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:31:38 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-03-02 12:31:38 +0200
commitd43a0047151d490dcd061e3f105bfc4eb9fac854 (patch)
tree93546657349fc5d8529376b7235ecc01bdaa73f2 /configure.ac
parentc55878df67c400d9ac940ee2d8dbd6e922af5ac3 (diff)
New example that shows C++11 support, build infrastructure for C++11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c4bec4..1496b60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,10 @@ THREADS
AM_CONDITIONAL([ODB_EXAMPLES_THREADS], [test x$threads != xnone])
+# Check for C++11.
+#
+CXX11([HAVE_CXX11], [Compiling in the C++11 mode.])
+
# Check for the ODB compiler.
#
ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])