aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-14 15:19:16 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-14 15:19:16 +0200
commit349178ecf6c69be63bd81ce81d310404574cb373 (patch)
treefccbd90c0cae4f43389ec830c9d7924c30c62113 /configure.ac
parent22dd2e8a904d26c18f6e4c634e14b21a8aaddc7d (diff)
Establish base build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 56 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a6d58d8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,56 @@
+# file : configure.ac
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([odb-examples], [__value__(version)], [odb-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([template/driver.cxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Check for threads.
+#
+THREADS
+
+AM_CONDITIONAL([ODB_EXAMPLES_THREADS], [test x$threads != xnone])
+
+# Check for the ODB libs.
+#
+LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+
+# Check which database we are using.
+#
+DATABASE
+
+case $database in
+ mysql)
+ LIBODB_MYSQL([], [AC_MSG_ERROR([libodb-mysql is not found; consider using --with-libodb-mysql=DIR])])
+ MYSQL
+ ;;
+esac
+
+# Check for the ODB compiler.
+#
+ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
+
+# Output.
+#
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([__path__(config_files)])
+AC_OUTPUT