aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
index 1650e41..6f64ff0 100644
--- a/odb/Makefile.am
+++ b/odb/Makefile.am
@@ -11,14 +11,21 @@ nobase_nodist_odbinclude_HEADERS = details/config.h
EXTRA_DIST = __file__(extra_dist)
+# At the moment, DllMain() is only necessary if we are using Win32
+# threads. So keep win32_dll_sources in ODB_THREADS_WIN32.
+#
+if ODB_WIN32
+nobase_odbinclude_HEADERS += __path__(win32_headers)
+endif
+
if ODB_THREADS_POSIX
-libodb_la_SOURCES += __path__(posix_sources)
-nobase_odbinclude_HEADERS += __path__(posix_headers)
+libodb_la_SOURCES += __path__(posix_threads_sources)
+nobase_odbinclude_HEADERS += __path__(posix_threads_headers)
endif
if ODB_THREADS_WIN32
-libodb_la_SOURCES += __path__(win32_sources) __path__(win32_dll_sources)
-nobase_odbinclude_HEADERS += __path__(win32_headers)
+libodb_la_SOURCES += __path__(win32_threads_sources) __path__(win32_dll_sources)
+nobase_odbinclude_HEADERS += __path__(win32_threads_headers)
endif
AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_DYNAMIC_LIB