aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-08-26 14:52:12 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-08-26 14:52:12 +0200
commit6fb470a39ef8900b71634333b0a2227dc8b62799 (patch)
tree6d782be7a2b25c3f21e9d25f7c7251bde2699994 /odb/Makefile.am
parentc883d0ba2f4450f35de6767355555fa83e6262ea (diff)
Add support for creating other build systems (meta-building)
Add support for automake, VC++ 9, and VC++ 10. Also add the Win32 and 'NULL' threading model implementations.
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
new file mode 100644
index 0000000..cfb0af8
--- /dev/null
+++ b/odb/Makefile.am
@@ -0,0 +1,26 @@
+# file : odb/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb.la
+libodb_la_SOURCES = __path__(sources)
+
+odbincludedir = $(includedir)/odb
+nobase_odbinclude_HEADERS = __path__(headers)
+nobase_nodist_odbinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+if ODB_THREADS_POSIX
+libodb_la_SOURCES += __path__(posix_sources)
+nobase_odbinclude_HEADERS += __path__(posix_headers)
+endif
+
+if ODB_THREADS_WIN32
+libodb_la_SOURCES += __path__(win32_sources)
+nobase_odbinclude_HEADERS += __path__(win32_headers)
+endif
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
+libodb_la_LDFLAGS = -release __value__(interface_version)