aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-08-30 15:50:24 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-08-30 15:50:24 +0200
commit289a99b42a16d69e9f97cef705669e04a3217581 (patch)
tree131301ca74003dce0c3e7bdea4d69cf53d0a3835 /configure.ac
parent2fe6da790e143e082bb512502b8d92c1f19ee870 (diff)
Support for automake and VC++ builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..30f3315
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,53 @@
+# file : configure.ac
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([libodb-tracer], [__value__(version)], [odb-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([odb/tracer/version.hxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT([win32-dll])
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Required by subdir-objects.
+#
+AM_PROG_CC_C_O
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Check for threads.
+#
+THREADS
+
+# Check for libodb.
+#
+LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+
+# Allow the user to specify the pkgconfig directory.
+#
+PKGCONFIG
+
+# Check if we should disable rpath.
+#
+DISABLE_RPATH
+
+# Output.
+#
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_FILES([
+ __path__(config_files)
+])
+AC_OUTPUT