aboutsummaryrefslogtreecommitdiff
path: root/odb/qt/Makefile.am
diff options
context:
space:
mode:
authorConstantin Michael <constantin@codesynthesis.com>2011-03-22 17:39:20 +0200
committerConstantin Michael <constantin@codesynthesis.com>2011-03-22 17:39:20 +0200
commit62996fbf441dc92d686e97f336b20a5fea972962 (patch)
tree09171cec997faff086c4918af32b2a8d49c72b57 /odb/qt/Makefile.am
parentdfb1ac9f19feacdce627b7e4bb20192bc71fe2d6 (diff)
Add dist build files
Diffstat (limited to 'odb/qt/Makefile.am')
-rw-r--r--odb/qt/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/qt/Makefile.am b/odb/qt/Makefile.am
new file mode 100644
index 0000000..d9fb5b4
--- /dev/null
+++ b/odb/qt/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/qt/Makefile.am
+# author : Constantin Michael <constantin@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-qt.la
+libodb_boost_la_SOURCES = __path__(sources)
+
+odbqtincludedir = $(includedir)/odb/qt/
+nobase_odbboostinclude_HEADERS = __path__(headers) __path__(options)
+nobase_nodist_odbboostinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)'
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined