aboutsummaryrefslogtreecommitdiff
path: root/odb/qt/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2011-04-24 12:20:21 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2011-04-24 12:20:21 +0200
commit422946df59a013e2d5512137497c0648575f1828 (patch)
treedbf759b12d3ff1ec2d58452ea01f1f8a5df35c2b /odb/qt/Makefile.am
parentc6584e488fe4f8962675ebda216ab22fde9aee52 (diff)
Fix dynamic library support in autotools build
Diffstat (limited to 'odb/qt/Makefile.am')
-rw-r--r--odb/qt/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/odb/qt/Makefile.am b/odb/qt/Makefile.am
index a923820..2c29ab2 100644
--- a/odb/qt/Makefile.am
+++ b/odb/qt/Makefile.am
@@ -12,5 +12,5 @@ nobase_nodist_odbqtinclude_HEADERS = details/config.h
EXTRA_DIST = __file__(extra_dist)
-AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)'
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_QT_DYNAMIC_LIB
AM_LDFLAGS = -release __value__(interface_version) -no-undefined