aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConstantin Michael <constantin@codesynthesis.com>2011-11-24 09:41:44 +0200
committerConstantin Michael <constantin@codesynthesis.com>2011-11-28 12:27:28 +0200
commitca2bec1322525e0c7ce5c316c3ed19b52d800bdf (patch)
tree1f05bc011bf30b96d07eeec69361ad16751d10cd /configure.ac
parent875ccee7c97f6040b17c85dd30e72e55061bacef (diff)
Add automake and Visual Studio build files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..15f6921
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,58 @@
+# file : configure.ac
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([libodb-oracle], [__value__(version)], [odb-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([odb/oracle/version.hxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT([win32-dll])
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Check for threads.
+#
+THREADS
+
+# Check for OCI.
+#
+LIBOCI(
+ [],
+ [AC_MSG_ERROR([oci is not found; consider using CPPFLAGS/LDFLAGS to specify its location])])
+
+# Check for libodb.
+#
+LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+
+# Define LIBODB_ORACLE_STATIC_LIB if we are build static library on certain
+# platforms.
+#
+STATIC_LIB([LIBODB_ORACLE_STATIC_LIB], [Static library interface.])
+
+# Allow the user to specify the pkgconfig directory.
+#
+PKGCONFIG
+
+# Check if we should disable rpath.
+#
+DISABLE_RPATH
+
+# Output.
+#
+AC_CONFIG_HEADERS([odb/oracle/config.h odb/oracle/details/config.h])
+AC_CONFIG_FILES([__path__(config_files)])
+AC_OUTPUT