aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-03 16:21:31 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-03 16:21:31 +0200
commit7e8e8aba7cc49bd26393c8f2cb07d99df9fec8dd (patch)
treecbbef7278026edf6ee1d9d93c9ef3df2e50bd001 /configure.ac
parentab9911fc1ed97bcfcb013c202c610a950609f979 (diff)
Add support for MinGW build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 39fb278..484a443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,10 +35,24 @@ LIBMYSQLCLIENT(
[],
[AC_MSG_ERROR([lib$libmysqlclient_name is not found; consider using CPPFLAGS/LDFLAGS to specify its location])])
+case $libmysqlclient_include in
+ short)
+ AC_DEFINE([LIBODB_MYSQL_INCLUDE_SHORT], [1], ["Short MySQL include."])
+ ;;
+ long)
+ AC_DEFINE([LIBODB_MYSQL_INCLUDE_LONG], [1], ["Long MySQL include."])
+ ;;
+esac
+
# Check for libodb.
#
LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+# Define LIBODB_MYSQL_STATIC_LIB if we are build static library on certain
+# platforms.
+#
+STATIC_LIB([LIBODB_MYSQL_STATIC_LIB], [Static library interface.])
+
# Allow the user to specify the pkgconfig directory.
#
PKGCONFIG
@@ -49,7 +63,7 @@ DISABLE_RPATH
# Output.
#
-AC_CONFIG_HEADERS([odb/mysql/config.h])
+AC_CONFIG_HEADERS([odb/mysql/config.h odb/mysql/details/config.h])
AC_CONFIG_FILES([
__path__(config_files)
])