aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-01-17 16:40:19 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-01-17 16:40:19 +0200
commit16054e2d129d7c5e956be7b33c29ae6c2ea5c962 (patch)
tree8d8f22207d3b763eb978f700e68ad74d657aa4c5 /configure.ac
parentc853481c254bcafeeca394faa9f4bb5205d4daa0 (diff)
Autotools and VC++ build support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f70bbaf
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,58 @@
+# file : configure.ac
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : ODB NCUEL; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([libodb-mssql], [__value__(version)], [odb-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([odb/mssql/version.hxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT([win32-dll])
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Check for threads.
+#
+THREADS
+
+# Check for ODBC.
+#
+LIBODBC(
+ [],
+ [AC_MSG_ERROR([ODBC is not found; consider using CPPFLAGS/LDFLAGS to specify its location])])
+
+# Check for libodb.
+#
+LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+
+# Define LIBODB_MSSQL_STATIC_LIB if we are build static library on certain
+# platforms.
+#
+STATIC_LIB([LIBODB_MSSQL_STATIC_LIB], [Static library interface.])
+
+# Allow the user to specify the pkgconfig directory.
+#
+PKGCONFIG
+
+# Check if we should disable rpath.
+#
+DISABLE_RPATH
+
+# Output.
+#
+AC_CONFIG_HEADERS([odb/mssql/config.h odb/mssql/details/config.h])
+AC_CONFIG_FILES([__path__(config_files)])
+AC_OUTPUT