aboutsummaryrefslogtreecommitdiff
path: root/odb
diff options
context:
space:
mode:
Diffstat (limited to 'odb')
-rw-r--r--odb/boost/version-build2.hxx.in2
-rw-r--r--odb/boost/version.hxx10
-rw-r--r--odb/boost/version.options2
3 files changed, 7 insertions, 7 deletions
diff --git a/odb/boost/version-build2.hxx.in b/odb/boost/version-build2.hxx.in
index f852792..17e901b 100644
--- a/odb/boost/version-build2.hxx.in
+++ b/odb/boost/version-build2.hxx.in
@@ -5,7 +5,7 @@
// @@ TODO: need to derive automatically (it is also hardcoded in *.options).
//
-#define ODB_BOOST_VERSION 2047200
+#define ODB_BOOST_VERSION 2047400
// The numeric version format is AAAAABBBBBCCCCCDDDE where:
//
diff --git a/odb/boost/version.hxx b/odb/boost/version.hxx
index 3576b02..fb74e05 100644
--- a/odb/boost/version.hxx
+++ b/odb/boost/version.hxx
@@ -31,23 +31,23 @@
// Check that we have compatible ODB version.
//
-#if ODB_VERSION != 20472
+#if ODB_VERSION != 20474
# error incompatible odb interface version detected
#endif
// ODB Boost interface version: odb interface version plus the Boost interface
// version.
//
-#define ODB_BOOST_VERSION 2047200
-#define ODB_BOOST_VERSION_STR "2.5.0-b.22"
+#define ODB_BOOST_VERSION 2047400
+#define ODB_BOOST_VERSION_STR "2.5.0-b.24"
// libodb-boost version: odb interface version plus the bugfix version. Note
// that LIBODB_BOOST_VERSION is always greater or equal to ODB_BOOST_VERSION
// since if the Boost interface virsion is incremented then the bugfix version
// must be incremented as well.
//
-#define LIBODB_BOOST_VERSION 2049972
-#define LIBODB_BOOST_VERSION_STR "2.5.0-b.22"
+#define LIBODB_BOOST_VERSION 2049974
+#define LIBODB_BOOST_VERSION_STR "2.5.0-b.24"
#include <odb/post.hxx>
diff --git a/odb/boost/version.options b/odb/boost/version.options
index 171b041..badb947 100644
--- a/odb/boost/version.options
+++ b/odb/boost/version.options
@@ -7,6 +7,6 @@
#
--hxx-prologue '#include <odb/boost/version.hxx>'
---hxx-prologue '#if ODB_BOOST_VERSION != 2047200 // 2.5.0-b.22'
+--hxx-prologue '#if ODB_BOOST_VERSION != 2047400 // 2.5.0-b.24'
--hxx-prologue '# error ODB and C++ compilers see different libodb-boost interface versions'
--hxx-prologue '#endif'