aboutsummaryrefslogtreecommitdiff
path: root/odb/boost
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2022-07-29 09:50:27 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2022-07-29 09:50:27 +0200
commit1fdcf34fa7140ec473d65a03658336c5387ef846 (patch)
tree2cd320ac2d95c6f5c095417b0ddd03bbc1385ac7 /odb/boost
parente25966c773cdfb800cb2598c13940183fc88b99e (diff)
Change version to 2.5.0-b.24.zHEADmaster
Diffstat (limited to 'odb/boost')
-rw-r--r--odb/boost/version-build2.hxx.in2
-rw-r--r--odb/boost/version.hxx10
-rw-r--r--odb/boost/version.options2
3 files changed, 7 insertions, 7 deletions
diff --git a/odb/boost/version-build2.hxx.in b/odb/boost/version-build2.hxx.in
index 1b8fbeb..17e901b 100644
--- a/odb/boost/version-build2.hxx.in
+++ b/odb/boost/version-build2.hxx.in
@@ -5,7 +5,7 @@
// @@ TODO: need to derive automatically (it is also hardcoded in *.options).
//
-#define ODB_BOOST_VERSION 2047300
+#define ODB_BOOST_VERSION 2047400
// The numeric version format is AAAAABBBBBCCCCCDDDE where:
//
diff --git a/odb/boost/version.hxx b/odb/boost/version.hxx
index c59b532..fb74e05 100644
--- a/odb/boost/version.hxx
+++ b/odb/boost/version.hxx
@@ -31,23 +31,23 @@
// Check that we have compatible ODB version.
//
-#if ODB_VERSION != 20473
+#if ODB_VERSION != 20474
# error incompatible odb interface version detected
#endif
// ODB Boost interface version: odb interface version plus the Boost interface
// version.
//
-#define ODB_BOOST_VERSION 2047300
-#define ODB_BOOST_VERSION_STR "2.5.0-b.23"
+#define ODB_BOOST_VERSION 2047400
+#define ODB_BOOST_VERSION_STR "2.5.0-b.24"
// libodb-boost version: odb interface version plus the bugfix version. Note
// that LIBODB_BOOST_VERSION is always greater or equal to ODB_BOOST_VERSION
// since if the Boost interface virsion is incremented then the bugfix version
// must be incremented as well.
//
-#define LIBODB_BOOST_VERSION 2049973
-#define LIBODB_BOOST_VERSION_STR "2.5.0-b.23"
+#define LIBODB_BOOST_VERSION 2049974
+#define LIBODB_BOOST_VERSION_STR "2.5.0-b.24"
#include <odb/post.hxx>
diff --git a/odb/boost/version.options b/odb/boost/version.options
index f10a507..badb947 100644
--- a/odb/boost/version.options
+++ b/odb/boost/version.options
@@ -7,6 +7,6 @@
#
--hxx-prologue '#include <odb/boost/version.hxx>'
---hxx-prologue '#if ODB_BOOST_VERSION != 2047300 // 2.5.0-b.23'
+--hxx-prologue '#if ODB_BOOST_VERSION != 2047400 // 2.5.0-b.24'
--hxx-prologue '# error ODB and C++ compilers see different libodb-boost interface versions'
--hxx-prologue '#endif'