aboutsummaryrefslogtreecommitdiff
path: root/tests/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/template/Makefile.am')
-rw-r--r--tests/template/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/template/Makefile.am b/tests/template/Makefile.am
index 9d198f1..d8b5b50 100644
--- a/tests/template/Makefile.am
+++ b/tests/template/Makefile.am
@@ -13,3 +13,9 @@ TESTS=$(top_builddir)/tester
TESTS_ENVIRONMENT=example=; export example;
CLEANFILES = test.out
+
+# Make sure make doesn't try to build the no-extension headers
+# thinking that they are executable. Those are pulled in through
+# auto-generated dependencies.
+#
+__foreach_w__(__f,__path__(xml_headers),$(top_srcdir)/xml/__f ): ; @: