aboutsummaryrefslogtreecommitdiff
path: root/examples/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/template/Makefile.am')
-rw-r--r--examples/template/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/template/Makefile.am b/examples/template/Makefile.am
index 64e4d1f..37d9509 100644
--- a/examples/template/Makefile.am
+++ b/examples/template/Makefile.am
@@ -11,3 +11,9 @@ AM_CPPFLAGS = -I'$(top_builddir)' -I'$(top_srcdir)'
TESTS=$(top_builddir)/tester
TESTS_ENVIRONMENT=example=1; export example;
+
+# Make sure make doesn't try to build the no-extension headers
+# thinking that they are executable. Those are pulled in through
+# auto-generated dependencies.
+#
+__foreach_w__(__f,__path__(xml_headers),$(top_srcdir)/xml/__f ): ; @: