aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2013-02-06 12:47:05 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2013-02-06 12:47:05 +0200
commit1c4d9141b013f4ab0c35be8b90f15d09c80abd9e (patch)
tree3eb7648c7da5e882d7fdc670f203a6ce0aaaf7bc /configure.ac
parent0c7ea7064e5bd6b19721f6d2ca87677dc476a190 (diff)
Add support for disabling threads
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 18f6dd1..49da0b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,7 +44,7 @@ if test x"$external_boost" != xno; then
LIBBOOST_REGEX([],[boost_found=no])
LIBBOOST_SYSTEM
- if test x"$boost_found" == xno; then
+ if test x"$boost_found" = xno; then
AC_MSG_ERROR([boost regex is not found; consider using CPPFLAGS/LDFLAGS or --with-boost=DIR to specify its location])
fi
@@ -55,6 +55,14 @@ fi
AM_CONDITIONAL([LIBCUTL_EXTERNAL_BOOST], [test x"$external_boost" != xno])
+# Check for threads. For now only internal Boost uses threads so don't
+# configure them if we are using external Boost.
+#
+if test x"$external_boost" = xno; then
+ THREADS
+ AS_IF([test x$threads = xnone],
+ [AC_DEFINE([LIBCUTL_DISABLE_THREADS], [1], [Disable threads.])])
+fi
# Define LIBODB_STATIC_LIB if we are build static library on certain platforms.
#