summaryrefslogtreecommitdiff
path: root/boost/pgsql/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'boost/pgsql/template/Makefile.am')
-rw-r--r--boost/pgsql/template/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/boost/pgsql/template/Makefile.am b/boost/pgsql/template/Makefile.am
deleted file mode 100644
index a1015c7..0000000
--- a/boost/pgsql/template/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
-# file : boost/pgsql/template/Makefile.am
-# license : GNU GPL v2; see accompanying LICENSE file
-
-EXTRA_DIST = __file__(extra_dist)
-
-noinst_PROGRAMS = driver
-driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
-LDADD = $(top_builddir)/libcommon/common/libcommon.la
-AM_CPPFLAGS = -I'$(top_builddir)/libcommon' -I'$(top_srcdir)/libcommon'
-AM_CPPFLAGS += -I'$(builddir)' -I'$(srcdir)'
-
-TESTS=$(top_builddir)/tester
-TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
-
-__ifelse__(__value__(odb_options),,,
-
-# ODB compilation.
-#
-driver_SOURCES += test.hxx
-nodist_driver_SOURCES = test-odb.cxx
-BUILT_SOURCES = test-odb.hxx
-CLEANFILES = test-odb.hxx test-odb.ixx test-odb.cxx
-
-ODB = @ODB@
-ODBFLAGS = @ODBFLAGS@
-ODBCPPFLAGS = @ODBCPPFLAGS@
-
-if HAVE_CXX11
-ODBFLAGS += --std c++11
-endif
-
-test-odb.hxx: test.hxx
- $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
-)