aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2017-11-07 10:37:53 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2017-11-07 10:37:53 +0200
commit6e374de9ae2f2978f2fca3390aba4ea3f72bfade (patch)
treea603c240f79494e0139445c20f63f32db04d5277 /odb/Makefile.am
parentfde4431ec608b467de6ab205e3f73848fe9efbdf (diff)
Switch to C++11, get rid of auto_ptr use
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
index a8d3ba3..c0d4ce1 100644
--- a/odb/Makefile.am
+++ b/odb/Makefile.am
@@ -9,6 +9,11 @@ plugin_LTLIBRARIES = odb.la
AM_CPPFLAGS = -I'$(top_builddir)' -I'$(top_srcdir)'
+# Note: not passed by libtool when linking odb.so. Seems to be harmless for
+# now.
+#
+AM_CXXFLAGS = -std=c++0x
+
EXTRA_DIST = __path__(headers) __path__(extra_dist)
# Plugin.