aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2013-02-06 12:12:42 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2013-02-06 12:12:42 +0200
commitf0016899eec4ff2ad61ef56a21e4132dd314a37f (patch)
tree74601096d27e17fcfb34dcf9ae1094795006b6e0 /odb/Makefile.am
parenta93f1b71722cc8862350614dca56e162aca2aa07 (diff)
Install plugin to pkgexecdir instead of bindir
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
index 1fa8298..5b976ea 100644
--- a/odb/Makefile.am
+++ b/odb/Makefile.am
@@ -2,7 +2,7 @@
# copyright : Copyright (c) 2009-2012 Code Synthesis Tools CC
# license : GNU GPL v3; see accompanying LICENSE file
-plugindir = $(bindir)
+plugindir = $(pkglibexecdir)
bin_PROGRAMS = odb
plugin_LTLIBRARIES = odb.la
@@ -19,7 +19,7 @@ odb_la_LDFLAGS = -module -shrext .so -avoid-version
# Remove the .la file from the final install.
#
install-data-hook:
- rm -f '$(DESTDIR)/$(bindir)/odb.la'
+ rm -f '$(DESTDIR)$(pkglibexecdir)/odb.la'
# Driver.
#