aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2013-03-19 15:02:31 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2013-03-19 15:02:31 +0200
commita2dee162af41c80827ff60d87c08ea981b55b31b (patch)
treec76f73c8b6652c5de54e36c3256570f408dd053b /odb/Makefile.am
parent29020cbfef6e3f797f7f76564d0f9b2663263f7b (diff)
Add support for installing plugin into default GCC plugin directory
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
index bc2fc76..f9d9703 100644
--- a/odb/Makefile.am
+++ b/odb/Makefile.am
@@ -2,7 +2,7 @@
# copyright : Copyright (c) 2009-2013 Code Synthesis Tools CC
# license : GNU GPL v3; see accompanying LICENSE file
-plugindir = $(pkglibexecdir)
+plugindir = @plugindir@
bin_PROGRAMS = odb
plugin_LTLIBRARIES = odb.la
@@ -19,7 +19,7 @@ odb_la_LDFLAGS = -module -shrext .so -avoid-version
# Remove the .la file from the final install.
#
install-data-hook:
- rm -f '$(DESTDIR)$(pkglibexecdir)/odb.la'
+ rm -f '$(DESTDIR)$(plugindir)/odb.la'
# Driver.
#