aboutsummaryrefslogtreecommitdiff
path: root/odb/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-02 22:25:48 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-02 22:25:48 +0200
commit2088891f11ab7aa3f843239cebe06a2850117b0b (patch)
tree3d80655c14ab4bc8101af4bc56e9ac99105a56d3 /odb/Makefile.am
parent4eb47d2965ca832243ed80f4140c34cfbed96863 (diff)
Add automake build system support
Diffstat (limited to 'odb/Makefile.am')
-rw-r--r--odb/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/odb/Makefile.am b/odb/Makefile.am
new file mode 100644
index 0000000..e8f2b40
--- /dev/null
+++ b/odb/Makefile.am
@@ -0,0 +1,31 @@
+# file : odb/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+plugindir = $(bindir)
+
+bin_PROGRAMS = odb
+plugin_LTLIBRARIES = odb.la
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
+
+EXTRA_DIST = __path__(headers) __path__(extra_dist)
+
+# Plugin.
+#
+odb_la_SOURCES = __path__(plugin_sources) __path__(common_sources)
+odb_la_LDFLAGS = -module -shrext .so -avoid-version
+
+# Remove the .la file from the final install.
+#
+install-data-hook:
+ rm -f $(bindir)/odb.la
+
+# Driver.
+#
+odb_SOURCES = __path__(driver_sources) __path__(common_sources)
+
+# Make sure common sources are compiled differently.
+#
+odb_CXXFLAGS = $(AM_CXXFLAGS)