aboutsummaryrefslogtreecommitdiff
path: root/tracer/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tracer/template/Makefile.am')
-rw-r--r--tracer/template/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/tracer/template/Makefile.am b/tracer/template/Makefile.am
deleted file mode 100644
index 4305788..0000000
--- a/tracer/template/Makefile.am
+++ /dev/null
@@ -1,31 +0,0 @@
-# file : tracer/template/Makefile.am
-# author : Boris Kolpackov <boris@codesynthesis.com>
-# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
-# license : GNU GPL v2; see accompanying LICENSE file
-
-EXTRA_DIST = __file__(extra_dist)
-
-noinst_PROGRAMS = driver
-driver_SOURCES = driver.cxx __path__(extra_sources) __path__(extra_headers)
-AM_CPPFLAGS = -I'$(top_builddir)/libcommon' -I'$(top_srcdir)/libcommon'
-AM_CPPFLAGS += -I'$(builddir)' -I'$(srcdir)'
-
-TESTS=$(top_builddir)/tester
-TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
-
-m4_ifelse(__value__(odb_options),,,
-
-# ODB compilation.
-#
-driver_SOURCES += test.hxx
-nodist_driver_SOURCES = test-odb.cxx
-BUILT_SOURCES = test-odb.hxx
-CLEANFILES = test-odb.hxx test-odb.ixx test-odb.cxx
-
-ODB = @ODB@
-ODBFLAGS = @ODBFLAGS@
-ODBCPPFLAGS = @ODBCPPFLAGS@
-
-test-odb.hxx: test.hxx
- $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
-)