aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 532140d..a44248d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,6 +15,10 @@ LT_INIT([win32-dll])
AC_CANONICAL_HOST
+# Check for diff.
+#
+DIFF_TOOL
+
# Check for C++ compiler and use it to compile the tests.
#
AC_PROG_CXX
@@ -30,6 +34,10 @@ THREADS
AM_CONDITIONAL([ODB_TESTS_THREADS], [test x$threads != xnone])
+# Check for the ODB compiler.
+#
+ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
+
# Check for the ODB libs.
#
LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
@@ -87,14 +95,6 @@ case $database in
;;
esac
-# Check for the ODB compiler.
-#
-ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
-
-# Check for diff.
-#
-DIFF_TOOL
-
# Define LIBCOMMON_STATIC_LIB if we are build static library on certain
# platforms.
#