aboutsummaryrefslogtreecommitdiff
path: root/common/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/template/Makefile.am')
-rw-r--r--common/template/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/template/Makefile.am b/common/template/Makefile.am
index eb1ae97..3cd0fb2 100644
--- a/common/template/Makefile.am
+++ b/common/template/Makefile.am
@@ -14,6 +14,8 @@ AM_CPPFLAGS += -I'$(builddir)' -I'$(srcdir)'
TESTS=$(top_builddir)/tester
TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
+m4_ifelse(__value__(odb_options),,,
+
# ODB compilation.
#
driver_SOURCES += test.hxx
@@ -27,3 +29,4 @@ ODBCPPFLAGS = @ODBCPPFLAGS@
test-odb.hxx: test.hxx
$(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
+)