aboutsummaryrefslogtreecommitdiff
path: root/libcommon/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-06 14:26:25 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-06 14:26:25 +0200
commit921c4c14c2999a03b9e649b5c9adec73b5cae0de (patch)
treec3a0015286ded8b59f2f44fd7b22be2748e16098 /libcommon/Makefile.am
parent0f9123ae095d3da7f2fb55d95af49ec3aa0a9c17 (diff)
Add automake build support
Diffstat (limited to 'libcommon/Makefile.am')
-rw-r--r--libcommon/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libcommon/Makefile.am b/libcommon/Makefile.am
new file mode 100644
index 0000000..d42cff2
--- /dev/null
+++ b/libcommon/Makefile.am
@@ -0,0 +1,12 @@
+# file : libcommon/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2010 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+noinst_LTLIBRARIES = libcommon.la
+libcommon_la_SOURCES = __path__(sources) __path__(headers)
+
+EXTRA_DIST = __file__(extra_dist)
+
+libcommon_la_CPPFLAGS= -I'$(builddir)' -I'$(srcdir)' -DLIBCOMMON_DYNAMIC_LIB
+libcommon_la_LDFLAGS = -no-undefined -rpath '$(libdir)'