aboutsummaryrefslogtreecommitdiff
path: root/common/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2011-11-21 16:32:59 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2011-11-21 16:32:59 +0200
commit47b943aa03a569fc23b9057ba572e9aeb63b5822 (patch)
tree025924808b51916113fe109c7d2b898af94f6a07 /common/template/Makefile.am
parent023cc1b06faa3e3ff6588ef4095f6e6badf19c17 (diff)
Add support for common tests without ODB compilation for automake/VC projects
Diffstat (limited to 'common/template/Makefile.am')
-rw-r--r--common/template/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/common/template/Makefile.am b/common/template/Makefile.am
index eb1ae97..3cd0fb2 100644
--- a/common/template/Makefile.am
+++ b/common/template/Makefile.am
@@ -14,6 +14,8 @@ AM_CPPFLAGS += -I'$(builddir)' -I'$(srcdir)'
TESTS=$(top_builddir)/tester
TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
+m4_ifelse(__value__(odb_options),,,
+
# ODB compilation.
#
driver_SOURCES += test.hxx
@@ -27,3 +29,4 @@ ODBCPPFLAGS = @ODBCPPFLAGS@
test-odb.hxx: test.hxx
$(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
+)