aboutsummaryrefslogtreecommitdiff
path: root/common/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2013-06-13 21:57:07 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2013-06-13 21:57:07 +0200
commit236cd9bb1dd022e64d690c9b0080d1a15c5f61c7 (patch)
tree2bcb891a85a64b2a4dfb7be457ea0bbbf519ccb9 /common/template/Makefile.am
parent2b03a8fa879bd583c889b101f567927a959cdc0f (diff)
Handle --database option directly in automake and VC++ projects
Diffstat (limited to 'common/template/Makefile.am')
-rw-r--r--common/template/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/common/template/Makefile.am b/common/template/Makefile.am
index 3571bc2..50ad1bc 100644
--- a/common/template/Makefile.am
+++ b/common/template/Makefile.am
@@ -35,6 +35,6 @@ BUILT_SOURCES += __f-odb.hxx
CLEANFILES += __f-odb.hxx __f-odb.ixx __f-odb.cxx
__f-odb.hxx: __f.hxx
- $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<
+ $(ODB) $(AM_CPPFLAGS) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) --database @database@ __value__(odb_options) $<
))