aboutsummaryrefslogtreecommitdiff
path: root/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'template/Makefile.am')
-rw-r--r--template/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/template/Makefile.am b/template/Makefile.am
new file mode 100644
index 0000000..4c76f3e
--- /dev/null
+++ b/template/Makefile.am
@@ -0,0 +1,28 @@
+# file : template/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : not copyrighted - public domain
+
+EXTRA_DIST = __file__(extra_dist)
+
+noinst_PROGRAMS = driver
+driver_SOURCES = driver.cxx database.hxx __path__(extra_sources) __path__(extra_headers)
+
+if DATABASE_MYSQL
+AM_CPPFLAGS = -DDATABASE_MYSQL
+endif
+
+TESTS=$(top_builddir)/tester
+TESTS_ENVIRONMENT=top_builddir=$(top_builddir); export top_builddir;
+
+# ODB compilation.
+#
+driver_SOURCES += __path__(odb_header_stem).hxx
+nodist_driver_SOURCES = __path__(odb_header_stem)-odb.cxx
+BUILT_SOURCES = __path__(odb_header_stem)-odb.hxx
+CLEANFILES = __path__(odb_header_stem)-odb.hxx __path__(odb_header_stem)-odb.ixx __path__(odb_header_stem)-odb.cxx
+
+ODB = @ODB@
+ODBFLAGS = @ODBFLAGS@
+
+__path__(odb_header_stem)-odb.hxx: __path__(odb_header_stem).hxx
+ $(ODB) $(ODBCPPFLAGS) $(CPPFLAGS) $(ODBFLAGS) __value__(odb_options) $<