aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8f341ff..9d8fd2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,10 @@ THREADS
AM_CONDITIONAL([ODB_EXAMPLES_THREADS], [test x$threads != xnone])
+# Check for the ODB compiler.
+#
+ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
+
# Check for the ODB libs.
#
LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
@@ -87,10 +91,6 @@ case $database in
;;
esac
-# Check for the ODB compiler.
-#
-ODB_COMPILER([], [AC_MSG_ERROR([odb compiler is not found; consider setting ODB variable or using --with-odb=DIR])])
-
# Output.
#
AC_CONFIG_HEADERS([config.h])