aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2010-09-03 16:20:38 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2010-09-03 16:20:38 +0200
commit0e2ae18a97fd507bac872031888d34c3a7d8b17b (patch)
tree3f9a551486969d2bc05f272e2da372c1a55d34cf /configure.ac
parent137b1eb3e41578d9d4a066ef75c6abfa597c46cd (diff)
Implement Win32 TLS support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 041c63e..fe1d59d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,10 @@ AS_IF([test x$threads = xnone], AC_DEFINE([ODB_THREADS_NONE], [1], [Have no thre
AS_IF([test x$threads = xwin32], AC_DEFINE([ODB_THREADS_WIN32], [1], [Have Win32 threads.]))
AS_IF([test x$threads = xposix], AC_DEFINE([ODB_THREADS_POSIX], [1], [Have POSIX threads.]))
+# Define LIBODB_STATIC_LIB if we are build static library on certain platforms.
+#
+STATIC_LIB([LIBODB_STATIC_LIB], [Static library interface.])
+
# Allow the user to specify the pkgconfig directory.
#
PKGCONFIG