aboutsummaryrefslogtreecommitdiff
path: root/odb/qt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'odb/qt/Makefile.am')
-rw-r--r--odb/qt/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/qt/Makefile.am b/odb/qt/Makefile.am
new file mode 100644
index 0000000..d9fb5b4
--- /dev/null
+++ b/odb/qt/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/qt/Makefile.am
+# author : Constantin Michael <constantin@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-qt.la
+libodb_boost_la_SOURCES = __path__(sources)
+
+odbqtincludedir = $(includedir)/odb/qt/
+nobase_odbboostinclude_HEADERS = __path__(headers) __path__(options)
+nobase_nodist_odbboostinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)'
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined