aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConstantin Michael <constantin@codesynthesis.com>2011-03-22 17:39:20 +0200
committerConstantin Michael <constantin@codesynthesis.com>2011-03-22 17:39:20 +0200
commit62996fbf441dc92d686e97f336b20a5fea972962 (patch)
tree09171cec997faff086c4918af32b2a8d49c72b57 /configure.ac
parentdfb1ac9f19feacdce627b7e4bb20192bc71fe2d6 (diff)
Add dist build files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac51
1 files changed, 51 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..82ccd12
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,51 @@
+# file : configure.ac
+# author : Constantin Michael <constantin@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+AC_PREREQ(2.60)
+AC_INIT([libodb-qt], [__value__(version)], [odb-users@codesynthesis.com])
+AC_CONFIG_AUX_DIR([config])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([odb/qt/version.hxx])
+
+AM_INIT_AUTOMAKE([-Wall -Werror foreign nostdinc subdir-objects dist-bzip2 dist-zip tar-ustar])
+
+LT_INIT([win32-dll])
+
+AC_CANONICAL_HOST
+
+# Check for C++ compiler and use it to compile the tests.
+#
+AC_PROG_CXX
+AC_LANG(C++)
+
+# Create the libtool executable so that we can use it in further tests.
+#
+LT_OUTPUT
+
+# Check for threads.
+#
+THREADS
+
+# Check for Qt.
+#
+#LIBQT([],[AC_MSG_ERROR([Qt is not found; consider using CPPFLAGS/LDFLAGS or --with-qt=DIR to specify its location])])
+
+# Check for libodb.
+#
+LIBODB([], [AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])
+
+# Allow the user to specify the pkgconfig directory.
+#
+PKGCONFIG
+
+# Check if we should disable rpath.
+#
+DISABLE_RPATH
+
+# Output.
+#
+AC_CONFIG_HEADERS([odb/qt/config.h odb/qt/details/config.h])
+AC_CONFIG_FILES([__path__(config_files)])
+AC_OUTPUT