aboutsummaryrefslogtreecommitdiff
path: root/odb/pgsql/Makefile.am
diff options
context:
space:
mode:
authorConstantin Michael <constantin@codesynthesis.com>2011-04-28 11:21:37 +0200
committerConstantin Michael <constantin@codesynthesis.com>2011-05-03 11:01:18 +0200
commit00eab4e6eca4227b1ecd2c6f502eedad41c3af96 (patch)
treecc3c7c33dc38f4002923567e9f7eb8087f17b2c3 /odb/pgsql/Makefile.am
parentf7f4d440622bc90c3aa491fd72951ae873505016 (diff)
Add libodb-pgsql infrastructure files
Diffstat (limited to 'odb/pgsql/Makefile.am')
-rw-r--r--odb/pgsql/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/pgsql/Makefile.am b/odb/pgsql/Makefile.am
new file mode 100644
index 0000000..2c61b75
--- /dev/null
+++ b/odb/pgsql/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/pgsql/Makefile.am
+# author : Constantin Michael <constantin@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-pgsql.la
+libodb_pgsql_la_SOURCES = __path__(sources)
+
+odbpgsqlincludedir = $(includedir)/odb/pgsql/
+nobase_odbpgsqlinclude_HEADERS = __path__(headers)
+nobase_nodist_odbpgsqlinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_PGSQL_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined