aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2012-06-15 11:16:44 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2012-06-15 11:16:44 +0200
commitaf2808859e7a98666785752b8069c473dda94a1f (patch)
tree123979c9700e588ad0f3007c19c096646dd73704 /configure.ac
parent5bfec1c98e05b86b719edb37ce1be8778f91d6ec (diff)
Add support for building against libmysqlclient that lacks THR_KEY_mysys
In certain distributions (specifically Fedora 15 and later), maintainers limit the number of visible symbols. If THR_KEY_mysys is hidden, then we try to create the TLS keys in such an order that it results in the correct behavior. And then hope for the best.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 01cf652..0902700 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,10 @@ case $libmysqlclient_include in
;;
esac
+if test x"$libmysqlclient_thr_key_visible" = xyes; then
+ AC_DEFINE([LIBODB_MYSQL_THR_KEY_VISIBLE], [1], ["THR_KEY_mysys is visible."])
+fi
+
# Check for libodb.
#
LIBODB([],[AC_MSG_ERROR([libodb is not found; consider using --with-libodb=DIR])])