aboutsummaryrefslogtreecommitdiff
path: root/odb/boost/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2011-01-31 10:53:27 +0200
committerBoris Kolpackov <boris@codesynthesis.com>2011-01-31 10:53:27 +0200
commit6a07b88cdf6419440b19e7b7dbc9231519c32c62 (patch)
tree995bdfbc256dd9ea444992a28d5750c8d0196d40 /odb/boost/Makefile.am
Initial Boost profile template
Diffstat (limited to 'odb/boost/Makefile.am')
-rw-r--r--odb/boost/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/odb/boost/Makefile.am b/odb/boost/Makefile.am
new file mode 100644
index 0000000..55d7816
--- /dev/null
+++ b/odb/boost/Makefile.am
@@ -0,0 +1,16 @@
+# file : odb/boost/Makefile.am
+# author : Boris Kolpackov <boris@codesynthesis.com>
+# copyright : Copyright (c) 2009-2011 Code Synthesis Tools CC
+# license : GNU GPL v2; see accompanying LICENSE file
+
+lib_LTLIBRARIES = libodb-boost.la
+libodb_boost_la_SOURCES = __path__(sources)
+
+odbboostincludedir = $(includedir)/odb/boost/
+nobase_odbboostinclude_HEADERS = __path__(headers)
+nobase_nodist_odbboostinclude_HEADERS = details/config.h
+
+EXTRA_DIST = __file__(extra_dist)
+
+AM_CPPFLAGS= -I'$(top_builddir)' -I'$(top_srcdir)' -DLIBODB_BOOST_DYNAMIC_LIB
+AM_LDFLAGS = -release __value__(interface_version) -no-undefined