aboutsummaryrefslogtreecommitdiff
path: root/xml/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2014-05-14 21:29:29 -0700
committerBoris Kolpackov <boris@codesynthesis.com>2014-05-14 21:29:29 -0700
commite897aa91a2a5c68a2f795f6a0a995600f13a85f8 (patch)
tree75a17430ba9cec822651b881003f66da8c89d7f9 /xml/Makefile.am
parent3bf332a7b77e9ce9e5eb0a1dfd5f64f238f4f17f (diff)
Convert to extension-less headers for API
Diffstat (limited to 'xml/Makefile.am')
-rw-r--r--xml/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/xml/Makefile.am b/xml/Makefile.am
index ebe357e..46be59f 100644
--- a/xml/Makefile.am
+++ b/xml/Makefile.am
@@ -20,5 +20,12 @@ endif
libstudxml_la_SOURCES += __path__(genx_sources)
nobase_studxmlinclude_HEADERS += __path__(genx_headers)
+nobase_studxmlinclude_HEADERS += __path__(xml_headers)
+
+# Make sure make doesn't try to build the no-extension headers
+# thinking that they are executable.
+#
+__foreach_w__(__f,__path__(xml_headers),__f $(top_srcdir)/xml/__f ): ; @:
+
AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -DLIBSTUDXML_DYNAMIC_LIB
AM_LDFLAGS = -release __value__(interface_version) -no-undefined