aboutsummaryrefslogtreecommitdiff
path: root/tests/template/Makefile.am
diff options
context:
space:
mode:
authorBoris Kolpackov <boris@codesynthesis.com>2014-05-14 21:29:29 -0700
committerBoris Kolpackov <boris@codesynthesis.com>2014-05-14 21:29:29 -0700
commite897aa91a2a5c68a2f795f6a0a995600f13a85f8 (patch)
tree75a17430ba9cec822651b881003f66da8c89d7f9 /tests/template/Makefile.am
parent3bf332a7b77e9ce9e5eb0a1dfd5f64f238f4f17f (diff)
Convert to extension-less headers for API
Diffstat (limited to 'tests/template/Makefile.am')
-rw-r--r--tests/template/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/template/Makefile.am b/tests/template/Makefile.am
index 9d198f1..d8b5b50 100644
--- a/tests/template/Makefile.am
+++ b/tests/template/Makefile.am
@@ -13,3 +13,9 @@ TESTS=$(top_builddir)/tester
TESTS_ENVIRONMENT=example=; export example;
CLEANFILES = test.out
+
+# Make sure make doesn't try to build the no-extension headers
+# thinking that they are executable. Those are pulled in through
+# auto-generated dependencies.
+#
+__foreach_w__(__f,__path__(xml_headers),$(top_srcdir)/xml/__f ): ; @: